Apache 2.2 + PHP 5.1 + MySQL 5.0

Поставил всё это чудо дома как обычно. Ничего особенного – там чуть-чуть изменить, тут что-то подправть. И обычно кое-как работать всё начинало.

Тут же все выходные пропарился с одной корявой проблемой – PHP в Apache работает. Но не может цепануться за дополнительные библиотеки (из папки php/ext). А без этого работают только встроенные библиотеки. Как только я не пробовал конфиги марновать, но толку никакого…

Стоит сказать, что именно эти версии я устанавливал специально для того, чтобы быть 100% совместимым с сервером на работе. Первое приключение началось, когда Апач не захотел схватиться за PHP – надо было ставить специально подправленную библиотеку.

А сегодня мне вечером в голову пришла гениальная мысль – а может это именно Апач виноват в том, что не дружат ПХП и MySQL? Конечно это что-то из области фантастики… Но как бы смешно нибыло, вся проблема именно в этом и была. После установки версии 2.0 и маленькой подстройки – все расширения заработали на ура!

Published by

Дмитрий Сычёв

Программист, сисадмин, геймер, велоездун, фотолюбитель... И вообще властитель всего мира этого блога. ;)

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.